Can’t join random worlds

I have a problem joining both random worlds and an existing world I’ve never been in.

When I join, it does a familiar “Searching…Please wait…” like I saw last year (Since I quitted Blockheads a long time ago). But about thirty seconds (or even later), it says a disappointing “Disconnected. The connection was lost.” I’ve tried this several times and it occurs the same result, even with Cellular data or Wifi.

Is it because my game has some problems, that requires some updates? Or it could be some other problems that I didn’t know? I’d like to hear some answers that could fix this problem.

  • SharpRO

(I captured the footage in video, but I can’t put it into this thread >_>)

Upload it to a cloud service and share the link with us.

Make it into a gif if it is short enough. I use Imgflip.com personally.

Got the link for the footage, don’t know if it could work or not.

I would check your search options. Make sure that it’s set to “either” for all categories. that’s usually the first thing to check if random world/search isn’t working.

1 Like

I tried, but it took me almost 20 minutes without results T~T

@Sharp-RO Hey, kindly reinstall the Blockheads app and do let us know if the problem still persists.

Same result ;-;

Guess I can’t play the game online…

Are you using a VPN? If so, try disconnecting it.

Thanks! It does work! Though this simple trick made me felt stupid from a week of waiting >->