Cannot upgrade armor bench


#1

I wanted to upgrade my level 1 armor bench to level 2 (Outside the Blocks, Mac server) so I took out all my iron ingots from my chest. But…

My iron ingots aren’t…real? Oh, the irony ! XD

I tried:
-Removing+replacing the bench
-Separting the iron ingots
-Dropping and picking up the iron ingots
-Using a different blockhead
-Leaving and reentering the server
-Leaving and relaunching the game
-Rebooting my phone

Nothing worked. The only way I could solve the problem was to create a new iron ingot from 3 ore and queue my blockhead to upgrade the bench while the ingot was being crafted.

I have absolutely no idea what caused this. All I know is that all my ingots were obtained from whacking a gold spade on unmined ore. Maybe the ingots… have a different ID somehow? (I noticed in 1.7, on my private mac server, I am unable to place certain regular dodo eggs in the same stack. They simply stay separated, and they still do. )
I was able to upgrade my easel and craft other benches with my other gold-spade-obtained ingots though. After upgrading the armor bench, I was also able to make iron armor with the same iron ingots.

???WHY??? :thinking:

Edit: iOS has the same issue. Moved to #bugs-glitches


#2

Okay I’ve seen your place in Outside the Blocks and I saw your armor bench already level 2 if this so your screenshot that while your lagging I think here the exclusive screenshot I have now you can level 3 it and you need 1 titanium ingot.


I hope now it’s already normal when you join in Outside the Blocks and you can now normally upgrade any benches you can and if not to try to fix your internet first :slight_smile:


#3

Oh boy, this bug is really rare! It’s only happened to me once.


#4

I am sorry that you were ripped off with your iron.
Blame potatoes iron dodos. Jk


#5

Wait what? xD


#6

I did manage to solve the problem eventually, by making a new iron ingot from 3 iron ore and then queuing my blockhead to upgrade the bench.


#7

I got the same issue on the same server when I was making my secret cave thingy

the first photo shows I have iron ingots but what’s interesting is that in the second one I apparently have -1 iron ingot :stuck_out_tongue:


#8

Quick, throw your iron ingots away! It’s eating you! It has superceded the dimensions and is now establishing total control on Outside the Blocks :smiling_imp: :smiling_imp: :smiling_imp:

I also like how the game realises that you need 2 iron ingotS to upgrade the bench if you have -1 iron.


#9

From my research iron ingots obtained through gold spades (not sure about picks) can’t be used to upgrade armour benches, and any ingots in a stack with iron ingots from gold spades will not work either


#10

You are a genius!


#11

Not really lol


#12

This happens to me too!