Cleaning up glitches (such as after griefers)


Added a section for removing super generators or super furnaces as some people call them. Basically, those super bright heat sources. Some say they can cause lag. I would say that’s true if you have dozens of them all over the place. I don’t think they would be any worse than having dozens of regular generators placed in a normal grouping.




This is when you have a tc server or hacking server.


That looks like simple water lag. How does that relate to TC abuse or hacking?


I don’t think it has anything to do with tc abuse, but it doesn’t look like the water isn’t actually flowing in most spots, maybe the water is being used to show a mass of glitched out blocks? Although it’s probably just normal water physics glitchiness.


When you get THAT much water trying to flow, especially on a server with a fair number of players logged in, it can do some very strange things. But yeah, there may be some glitchy block artifacts, maybe flax mats, or corrupted blocks.


We should add a section about getting a trusted friend to help you clean up and how to ban griefers/hackers.


The OP has now been updated with a fix for glitched trapdoors. :slight_smile:


I have realized that the last hacker that came on my server left an extremely important trapdoor not working and glitched out. I tried the method shown on the post for glitched trapdoors but it doesn’t work and I’m not sure why. The trapdoor doesn’t work at all and when I look at it from different angles it changes its appearance, from trapdoor to partially trapdoor and even to just looking like a solid block.

Whenever I try to use the method mentioned above, I am only able to get rid of the door and not the top block.

How do I solve this issue or am I just completely wrong with what I’m doing?


Sounds like something different went wrong than is normal, what’s your server? I can come take a look this evening and try to fix it.


I’ve experienced something like this and with the door trick managed to turn it from a glitched trapdoor into a glitched door (where you see the doors on the sides, but no block substance). I couldn’t get rid of it, but I logged off in frustration and when I came back the bad door was gone. So, a server stop might have fixed it. Just FYI.


@Bibliophile My server is called Brigade and the glitched trapdoor is on the floor below the spawn portal in the center. Please come help me get rid of it!:disappointed:
@jemnidad I tried that too and it doesn’t seem to work either.


I got on and found the glitch. Can’t do much yet.


@Bibliophile I had a glitchd space, I tried using the method at the top for fixing glitched spaces but it didnt work. I merged the ideas of Fixing Glitched Spaces, and the ice sign method, and it worked! May want to look into it.


Yea, multiple methods together can help a lot. I added a note to the OP about trying multiple methods at once.


I was just going to reply to Jemni’s elev-door fix with what I do when you can’t remove door, and you just discovered it! Nice job! It doesn’t require ice. It does require that you have two blocks on one side of the door next to both upper and lower parts of the door, nothing on the other side, and then place a sign on the top part of the door. This forces it to center the sign evenly over block on left and top of door…as in your picture. It works every time for me. (Except for severely glitchd spots…which then requires me to stack two elev-door ensembles evenly over glitched spaces…)


@KP7 Thank you so much for sharing the merging of the ice/sign method and the door and elevator trick! It actually worked for me! :stuck_out_tongue_closed_eyes:


Lol. I actually wast looking to fix glitched doors but I’m glad it helps. :slight_smile:

Looks like I found fixes for more than one thing! Yay


Bib, this was a fantastic and sorely needed post. Thank you so very much for composing all the explanations. I’ve wanted to understand a few of these for a long time and I’m so I’m glad I now have a place to come to. Great work!!!



I have a elevator moter that wont budge. I tried everything I can think of to remove it but I just can’t. Waht should I do??