Cleaning up glitches (such as after griefers)


I tried using it on a glitched trade portal and it like got rid of it but I couldn’t place another trade portal down what did you do?


Ok, one extra piece of info. Just saw this on @DGPG’s server and it stumped him too. There are sometimes a column of bad glitched blocks, and if any glitch space is in the 3 blocks that your portal needs to occupy, then it might not let you place it. So…start under the bottom most glitched square. Below that place your elevator, then door, then remove. Work your way up as each square should get fixed from the bottom up.

Trade portal missing the portal part


I hope this helps!


Someone greifed on my server and I can’t fix it. I’ve placed a trade portal on it and then destroyed it but it’s only worked twice


Help I tried /stop but it didn’t work this keeps happening in protected areas all our signs get destroyed and this happens to our trade portals


I tried the bed trick it worked but for these two it didn’t help

Didnt work for these either


@White_Rose, I know you are really desperate for help, but please don’t post so many times in a row in less than an hour. If you want to add more information to a post you can use the pencil icon to edit so that everything is contained in one post. If someone else posts or more than an hour has passed then you can make a new post. :slightly_smiling_face: This is a complex rule, you can read it explained a bit better here:


It sounds like you just need to get your server a rollback. That is a really bad clean up job.


I agree with Shariu, but what server is this? Maybe I can help.


@Bibliophile. I have a suggestion you add to the list.

Removing glitched doors
Place a trapdoor on the top of the door
Remove the door (the trapdoor should be glitched)
Place the door under the glitched trapdoor
break the top of the door


This is a wiki, you could add them if you want to.


Wow i can. I thought that was a regular thing
Thanks porky


Only regulars can make them but trust level 1+ can edit them.


this theard is is allowed for bumb


I have found another glitch, on Basileus. I have no idea how to replicate it, and as such was wondering if it could be fixed

Somehow empty space has been acting like a block removed by your hand
So far none of the fixes have worked


It’s not an invisible flax mat block is it? Can you place a block next to it and put a sign on that?


No it isn’t a flax mat. It isn’t anything I have ever encountered before. I tried all the usual clean up tricks. None of them worked. Whatever tool you try to use on that space it shows the hand and acts like it is picking something up. Nothing is added to your inventory.


You did try ember I assume?


Yes we did. The glitch was made by the recent burning of that house. Here is a picture of the post with the block that is now glitched circled in red.

I have noticed fire making visual glitches before but never anything like this.


Did yu try putting a door 1 block bellow it?