Common bugs and glitches


#1

This thread is for common glitches and issues, and so that you can maybe find a fix for them. If you have issues, try to find it here, and maybe you’ll find a solution. :smiley:

[U]The Random supersonic teleportation glitch[/U]

Well, the title makes it sound more exciting than it is. :stuck_out_tongue: Basically, your blockhead randomly zooms to another spot a few thousand blocks away. It leaves a trail of uncovered spots in the fog of war darkness.

FIX: No real fix, and currently no known triggers yet. You might just have to walk back. If you’re REALLY lucky, maybe catch another one of these back :stuck_out_tongue:

[U]The double-placing glitch[/U]

Basically, if you’re on a laggy world and you place something but it doesn’t load up yet, and then you place something else there while it’s loading, two things could happen - one of the things will drop, or one will disappear.

FIX: Unfortunately, if it’s gone it’s gone. Avoid doing this, and wait until the thing loads before doing anything else.

[U]***The North Pole Handcar Glitch:***[/U]

You’re riding your handcar past the north pole when suddenly your blockhead disappears. You jump off of your handcar and find that the handcar you used can’t be used anymore!

FIX: I’ve heard people say that if you don’t get off your handcar and crash the handcar into something instead, you will still be able to use your handcar. I haven’t confirmed it yet.

[U]A strange type of world corruption[/U]

Your world gets corrupted! It’s a weird, and unfixable glitch that does a lot of weird things, including:

-Things turning into level one workbenches that are UNUSABLE
-Items randomly turning into golden chests
-Upgraded portals and workbenches going back to level one

FIX: None that I’ve seen. It appears to be, unfortunately, world corruption that can’t be fixed. You can try to use the items in the golden chests if you can get into them, and you can also try to salvage the materials from some of your old structures. You can move to another part of your world IF POSSIBLE (It might not be, there might be too much damage, or things might be weird in this world forever), or, if your portal chest works, which it might not, you can try to move your items to a new/other world. If not, then unfortunately you will have to start all over from scratch. :frowning: Good news is that this is very unlikely to happen. I’ve played this game for quite a while and I’ve never had this happen to me.

[U]The Door bug[/U]

Your blockhead for some reason decides to climb over a building instead of walking through the doors! This is most often caused when the inside of the building isn’t properly or completely loaded, however this is not permanent and will not damage your world.

FIX: Tapping inside of a building seems to work in most cases.

[U]The elevator isn’t working!!![/U]

Sometimes, when you place your elevator motor, the elevator doesn’t work properly!

FIX: Try picking up and replacing the elevator motor.

[U]The Walking glitch[/U]

You’ve told your blockhead to walk somewhere and you exit the game. When you come back in, your blockhead is walking on the spot!

FIX: Although it is annoying, you just make your blockhead walk there again. Sometimes this will happen again when you exit the game, so you may need to repeat this a few times.

[U]The Donkey bug[/U]

You try to mount onto a donkey. When you mount on, it looks like you’re siting on the air!

FIX: No worries, nothing bad happens, just get off and mount the donkey again!

[U]The Background Item Glitch[/U]

For whatever reason, sometimes wire/chests/ladders/torches/lanterns will not work properly anymore, and will become the background., and it will work and behave like the background, so you won’t be able to interact with it anymore, because it will be background.

FIX: Try removing the back wall if possible by removing the block (don’t use a pickaxe or you might lost the chest), if you’re in a cave or for whatever reason can’t remove the backwall, then try pouring water over the glitched item, sometimes that will work and fix it. Also try to place a bed over ti and then sleep in the bed, which has worked in some cases. If that still doesn’t work, then I don’t know any more fixes, you can place items and blocks over the glitched item if you wish to do that.

NOTE: Torches and lanterns affected by this glitch will continue to produce light, however they can’t be removed properly. Ladders, chests, and wires affected by this glitch will not work at all, you can’t open the chests, you can’t climb the ladders, and the wires won’t conduct electricity.

[U]***The Hungry Freight Car!***[/U]

Okay, so apparently, your freight car got hungry and ATE THE ITEMS YOU PUT INSIDE!!! (Mmm, delicious steel ingot!;)) In other words, items that you put in our freight car disappear when you open it!

FIX: Sadly, your items are gone. No fix.

[U]The Corrupted Area[/U]

Sometimes, your game crashes whenever you look in a certain area. Most or all cases have occurred on Cloud servers. Everyone on an affected server is prone to the issue as far as I’ve seen.

FIX: No fix known yet, just try not to look in that area, though the rest of your server should be safe. If your blockhead somehow gets into that area, your game will most likely crash every time you enter that server.

[U]The Unknown Glitch[/U]

There’s a regular-looking item in your inventory…and it’s called “UNKNOWN” instead of the item’s name, and it doesn’t work like the item, but it works like your hand! Sometimes, you’ll see “UNKNOWN” time crystals…in your inventory!

FIX: No fix for those items, and it’s currently unknown what’s causing the issue.

[U]The Boat/train with a mind of it’s own…[/U]

This glitch happens on multiplayer, especially on servers with lag. You get off your boat, handcar, or train, but the vehicle keeps moving!

FIX: Just chase after it. Often you’ll find it spinning around in circles, which is a bit odd. It should still work though.


Jetpack glitched entire world
#2

The donkey glitch? When you try to get on a donkey but you are just sat there on nothing and can’t move…


#3

Another issue with elevators is when you have a huge amount of steel around your elevator and possibly connecting to far away power generators of some sort. The circuit gets confused and nothing will work. Try insulating the elevator from the other power source with stone or another non-conductor.


#4

Floating donkey rider as well. Fix is just tap out and tap on donkey with carrot on stick. Pretty sure it happens in just walking a distance long enough that the donkey you selected has moved, but the coding requires you to go to that exact spot.


#5

Added the donkey glitch. Jemnidad, I didn’t add your elevator problem as I haven’t seen it be reported on the forums a lot. This is only for common bugs and glitches. Sorry!


#6

Sticky this Milla/BlockheadBean/majicDave/dropbear?


#7

since i know quite a few players didnt update because of death, add the floating dropbear glitch?


#8

Well, most people have (and should have) updated to 1.5, so if you’re on the current version, which you should be, then you shouldn’t be having that issue.

(Wow, posted exactly an hour apart! :D)

EDIT: And Andrew, Dropbear isn’t active anymore. ;))


#9

Oh-The thousands of dropbears glitch!


#10

I got this on pic! I got this on pic! These sharks are oversized. Huge. Then disappear almost as soon as you see them. If you haven’t looked at an area in a long time, then they grow overly big. They even roll down to the bottom down here. Here’s some pics of them.



There is a HUGE one in each of these pictures.


#11

Yay! It is sticky!


#12

I get that on servers too! It scares you when your just riding a boat and then that appears XD


#13

When you play multiplayer, and you’re riding a steam locomotive, and then the passenger car just go off


#14

I added the train station issue with steam locomotives.

Also, thanks to whoever stickied this! (My first sticky! Yay! :D)


#15

I added the background item glitch, it seems to be a recurring issue with many players.


#16

IT’S THE MEGALODON SHARK!!! (swim for your lives before it swallows you WHOLE xD)


#17

can you guys add the bug wherein putting items in freight cars will end up disappearing for no reason. this bug happened to me and i have also found a little old thread for it. http://theblockheads.net/forum/showthread.php?7373-Freight-car-loses-items&highlight=freight+cars

i was so sad when it took away my railroads :frowning:


#18

It’s probably been fixed in the recent update, I haven’t seen any threads about it since 1.5 came out.


#19

please tell me you’re serious…after the update, i made this post. Meaning that the new update still has this bug. im sure no reports are happening since everyone is scared to use it. Im very sure this bug is still there after first hand experience after the update


#20

Really? Okay, I’ll add it in. :smiley:

ALSO ADDED: The stairs Achievement Glitch, it seems that A LOT of us are having that issue.