I can't update to 1.7!