Not able to watch any ads for time crystals


#1

I was able to watch ads for time crystals when i started playing but after a few days they stopped. I have not been able to watch a single one for weeks now and mining time crystals isnt enough to continue progressing in the game. My girlfriend who also plays has been able to watch ads consistently since starting with no issues on the same wifi connection. Any suggestions on how i can fix this? I dont want to have to reinstall and lose my world as i have lost access to a previous world once already.


#4

What kind of device are you using? If you are using an Apple device running iOS 11 or later, you could possibly offload the app and reinstall it.


#5

Im on a lg g6 android v8


#6

Majicdave said that 1.7 will make TC ads playable once per 10 minutes, but this isn’t the case for some people (me because I watch a TC ad once per a few minutes, and some people like you, Dunmer13, weren’t even able to watch a single ad).


#7

Have you tried messing around with the time on your phone?


#8

I have not tried changing the time on my phone but as i said its been weeks now with zero ads. My gf is also definitely able to watch more than 1 per 10 minutes, hers are always available.


#9

I finally broke down and just bought some tc for cash hoping maybe a purchase would restart my ads. It did not. And what i bought didnt even get my trade portal max smh


#10

Ads are generally limited by advertisers into your territory, but if your girlfriend is getting ads it sounds like it’s either device specific, or it’s a problem with your install, if she’s on Android too. Don’t delete the app. Try contacting the support email linked to in the Support section of the HELP/CREDITS screen, reached from the pause menu. I only support Apple, but they are dedicated to the Android build, and might be able to advise.


#11

I emailed them about a week ago with no response yet, why i thought I’d give the forums a try. But thank you for taking the time to respond


#12

Did you reply to their automatic email? They send out the fixes for the most common problems, and if you don’t reply they assume one of them solved your issue.


#13

Yes i replied to the auto mail the day i got it. I tried emailing them again yesterday with more information, hopefully i will get a real response soon.


#14

The last time I had this problem I just restarted my iPad. I’m not an android person but restarting devices usually fixes problems inside or outside of apps.


#15

I thought the same thing a few days in but restarting did not fix problem