Ownership Sign on LAN server (ios)

So…umm. I created a single player world with custom rules and had been working with it for quite some time now. There are few times that I host my world to LAN so me and my cousin can play together. Then there’s that one time that I placed an ownership sign on one of my buildings (while playing solo / single mode this time). The first thing i noticed when I press the ownership sign is that there are two buttons:
Remove Sign
No owner
What I want is to assign the ownership to my name, so I thought it won’t work if I’m not playing multiplayer or LAN mode. So with this, I went back to menu screen and hosted my world to LAN. Then, upon pressing the ownership sign again, to my surprise, the buttons I saw were:
Remove Sign
Ban Aren (Aren is my LAN/multiplayer name)
No owner
Owner: King (King is the LAN/multiplayer name of my cousin)

In this part I was really confused, and here are the questions I’ve been wanting to ask in this forum.

  1. Why can’t I set the ownership to my name? I am the one who made the world, I am the one who made and placed the ownership sign, and yet my cousin instead of me gets the option to own the ownership sign. (Also my cousin wasn’t in the world at that time because he was playing a different game.)

  2. Why is there an option to ban myself from the ownership sign? I mean, why would I even ban myself to an ownership or world I made?

  3. Summing up my first and second questions, it feels like my cousin is the admin / owner of the world, and I am the one joining in, which is obviously wrong in all ways. This 3 questions made me think that I’m having a glitch on that part.

I hope everything will be answered in this forum 'cuz I’m really lost at this point.

1 Like

This seems to be really weird.I have never used ownership signs on single player worlds, so I don’t know if there is a glitch with them. I didn’t even know you can even place a protection sign in single player mode.
But you might want to try this:

  • set it to “no owner” first, then try to set it to Aren
    or
  • remove it and place it again when the world is in LAN mode
1 Like

Upon placing the sign, the default selection is ‘no owner’, and the only other button i see is ‘King’ (i take the meaning of that is to set the owner to my cousin ‘King’).

Also, i tried what you suggested in bullet 2, but still doesnt work. :frowning: (I also tried crafting the ownership sign on LAN mode)

Just want to ask this tho, what does ‘no owner’ mean in a multiplayer? Does that mean all players cant touch the protected areas aside from the admin cuz there’s no specific owner? Or does it mean All players can do what they want with the protected area cuz there’s no specific owner?

No owner signs usually just means unassigned protection, nobody has an exclusive right to modify it except the world’s admins and owner, both of whom can bypass the signs in the first place.

2 Likes

I thought protection signs didn’t say that…

They don’t. The OP was inquiring about default selection, not default display.

I’d assume these ones also show the usual AREA PROTECTED when set to no owner.

Ohh so ‘no owner’ means means only me (the owner) can modify the protected areas?

If that’s the case, then that explains everything :slight_smile: I thought the no owner meant all players can modify it since there’s no ownership. Thanks for the answer mate, glad I posted here :slight_smile:

Basically yes, but just to be precise: admins can also modify the area if set to “no owner”.

1 Like

I see. So this one’s not a glitch after all, just a concept misunderstanding on my part lol :slight_smile: Anyways thanks for all the replies. you’re a life saver :blush: