Solutions to crashes and multiplayer / Game Center problems


#1

Hi guys

It’s really fantastic to see people playing and enjoying The Blockheads!

I probably won’t be posting a huge amount here, I need to keep working hard on adding updates to the game! But I just thought I should comment on a couple of issues that are popping up.

The crashes are mostly caused by a single bug related to playing music. I have already fixed it here, and will be submitting the update shortly. In the mean time, you should be able to stop the majority of crashes by playing your own music before starting the game. Sounds crazy, I know, but it should work!

The other thing I want to mention is multiplayer. Due to limitations in the way Game Center works I wasn’t able to implement auto matching for multiplayer. I also couldn’t disable the auto matching user interface. It’s misleading I know and I hope to fix it somehow. But for now, the only way to play multiplayer is to invite a friend.

There are also a few other limitations. If you have problems, make sure both devices have the same version of iOS. Also, you must have Game Center notifications turned on on the device for the person getting invited.

Hope this helps, and I’m sorry for any issues you find. Hope you’re having fun!


#2

I can’t seem to get voice chat in 2 player to work at all. Do I need to use headphones or something?


#3

Sorry, I should have mentioned that also. When Game Center decides the connection isn’t quite fast enough to handle voice chat on top of the gameplay, it disables it. So the solution is to try to get both devices on the best wifi connection you can, and just keep trying (by re-inviting and waiting for 10 seconds or so), often it will work after a few tries.


#4

Earlier today, i tried connecting with my friend that wasn’t using the same internet connection as me, it didn’t work and halfway through it said [Insert name here] has disconnected. and then as for my friend it says ___ has left. what.


#5

Hi everybody,
I’m currently having a crash-problem, where as I load my world, the second it finishes Loading, the game crashes.
I tried making a new world, but that also crashed. I have the newest version, with the bug fixed, i ran the game smoothly for 3 hours, and play it on an I-Pod 3 with ios somewhere above 6.3 (lost track of that). The Crashes came after I completed my armour-making-thingy (crashed .5 sec. after that finished).
Please help, im currently close to Steel, already got the needed workbench, so it would be a pain to start it all over again!! :frowning:


#6

Well you best bet would be to check you giga bytes to see if you have alot or enough to be fast/stop crashingcrashing
or delete and reinstall the game


#7

What about a message saying “Multipllayer Unavailable. You are not allowed to play multiplayer games on this device” im not jailbroken and i am signed into gamecenter but when i tap “2 PLAYER” there’s a popup with that message.

iPod Touch 4 8GB iOS 6.0.1
The Blockheads version: Latest, whatever that is :stuck_out_tongue:


#8

It seems there is a setting you need to change. Have a look at this for the solution:


#9

Whoa I didn’t even know I had restrictions turned on :p. Thanks for pointing that out.


#10

Ppl are talking about updates on here. How do I update?!? :confused:


#11

The update has been submitted to Apple but is not approved in the App Store yet. At least not in Canada’s App Store. Once it’s approved we’ll be able to update.


#12

Update is now approved and available.


#13

Updated on new update still crashing And first world that crashed erroed still wont run game crashes and i put a torch everything is dim i take it off and its bright lols


#14

Um…you go to the app store, and tap on updates. (DUH)


#15

alrighty heres a problem for ya. my brother and i started a world, we got afew hours in and started making a trip around the world. we reached the south pole and went on for another hour, but than we decided to look ahead to see if we were ever going to get back to home base. his app crashed yet mine said he was still on , when i zoomed to his name, it showed that he was inside of the home portal, even though he obvipusly wasnt. so i exited the game and went to reinvire him, when he clicks the invite message - i connect, and he is stuck on the connection screen with 50% progress

ive tried -
-restarting both apps on both devices
-starting a new world and inviting him there (that actually works, but i want to be in the world we just spent hours in)
-unfriending him, refriending him on game center, doesnt work

so hopefully you can help


#16

both are ipad 2s running ios6


#17

To update, go to the App store, and in the bottom right click update apps


#18

Ok. Here’s one for ya…I was going around the world and was in a boat when it crashed. When I logged it back in, my boat was gone :frowning: soooo… there I was in the middle of the ocean. -_-


#19

It’s not much fun that. I’ve had similar in caverns where my blockhead was down to one lantern carried, the game crashed, and when I restarted the dozen or so lanterns last placed weren’t working anymore. Long painful inch by inch back to an area where they were.

You might like to make more than one boat - there’s no limit AFAIK on how many you can carry. You might also want to wait until the update due this Friday that may fix the save problems that result in the loss of in game items from crashes.


#20

Same problem here