The Blockheads 1.7 Launches March 15th


#1832

Well now that 1.7 is out I’m gonna probably go play modern combat versus or somethin


#1833

MY SISTER HAS IT!!! OMG OMG OMG!!! 1.7 IS FINALLY HERE!!! I have to watch my sister play it though… She just downloaded it, school’s over! But I can’t get it, because my Chromebook is flat… :cry::cry::cry::cry::cry::cry::cry::cry::cry:


#1834

I have to say, Dave, you have really outdone yourself with this update. It reslly is wonderful. There is so much new stuff I feel almost like this is a new game I haven’t played before. Thanks! :slight_smile:


#1835

I thought, that @majicDave and @milla can take a breathe of all this madness of the update…
I’m very thankful for the update


#1836

The 1.7 update almost made me cry real tears I love it so much


#1837

@milla, don’t have it. When I go to the App Store… It gives me the option to “Open” Version 1.7. When I press that button, it brings me to the BH app which says that I need to update.
"Update Required
There is a new version of the blockheads available. Please update so you get all the latest features and bug fixes, and can continue to play online."
with an OK button.

  • I’ve tried closing out. Restarting my device. Hard reset of my device. Sign out of Apple ID and resigning into my Apple ID. Turning off wifi and trying with cellular.
  • I’ve also tried updating other game apps, and have no problems doing so.

I’m stuck.

The last resort that I’m considering (and I just backed up my iPad right now to get ready), is to download the test flight 1.7 beta version… and see if that does something. If you know that that will be a disaster, let me know.


#1838

@Thuthu, I had to search for the Blockheads on the App Store to get it to work for me. I couldn’t just check my updates. See if that helps any. Hopefully it will!


#1839

I did search, @djfamily. That was how I was getting to the blockheads app page.

HOWEVER, I just downloaded the last beta version and it works for me now. @milla, I’m all good. :slight_smile:


#1840

It gave me a bit of trouble, but I guessed it was bc I was anxious. Glad you are good now :slight_smile:


#1841

NO I can’t see the update on the App Store!


#1842

I am riding a dodo!


#1843

I think that when someone swears in chat it should be :face_with_symbols_over_mouth: instead of :rage:.


#1844

No it shouldn’t because most can’t see the :face_with_symbols_over_mouth: symbol from iOS 11.

Um… hey Dave, I think my blockhead has seen things she shouldn’t have…
image
Her look on her face tho tells me something.


#1845

@milla, i still cant get it. I don’t have to update. Rip


#1846

I’m pretty sure it’s along the lines of the app store having to register the idea that an update exists


#1847

The app store broke. I had to uninstall and install.
At least I rode a unicorn!


#1848

i don’t have a apple id yet because my school did not set it up and i want to get it so bad


#1849

Yes!!! Just after my birthday too!
Just checked. It’s today :sweat_smile:


#1850

A h Y e a .


#1851