The Message Bot


#1562

So, my extensions page looks like this at the top:

Press the Load By ID/URL button.
Then enter “quests” in the popup and press “Load”. That’s it.
Then you go to the extension tab for the newly installed Quests extension.

It looks like this:

go to Quests and start creating the quests you want, and define Levels, and other settings.


#1563

mine looks like this: https://screenshots.firefox.com/o8cyGPd1uxj2uhGm/portal.theblockheads.net

i entered All Quest quest and quests and Quests


#1564

So…nothing is added when you use the extension ID?

Looks like you aren’t using any extensions, so if I were you I would update to start using version 7.

I recommend making a separate bookmark for it and using this URL:
javascript:(function(){if (!window['@bhmb/bot']){document.head.appendChild(document.createElement('script')).src='https://gitcdn.xyz/cdn/Blockheads-Messagebot/Browser-Loader/master/bundle.js';}}())


#1565

Thank you, it now works


#1566

did you get the new version working? Going forward, it will work better and have more features. I’m just waiting on the migration part for banking and XP. (hint, hint @Bibliophile)


#1567

Well, it took long enough…

Version 7 is complete!

This is a completely rewritten bot which was made with Mac servers in mind. There isn’t a complete working Mac version/guide yet, but it shouldn’t be that difficult to set up if you are comfortable with a bit of command line work.

Partial change list

You can now drag messages around to re-order them, if on PC

Custom extension repo urls - if you want to host an extension that only you can install

Default: https://gitcdn.xyz/cdn/Blockheads-Messagebot/Extensions/master/extensions.json
Wingysam’s https://mb.wingysam.xyz/

image

You can now download/upload backups instead of copy-pasting crazy long strings.

There is now a much better log viewer/searcher that makes it easy to track down issues in chat.

image

Released the quests extension - with support for multi-tiered quests!

You can now use a custom help command for man pages, and it defaults to /? instead of /help to avoid spam when staff use it.

Behind the scenes improvements

  • Extension installs are no longer global, so you can have different extensions installed on different servers without having difficulty
  • The bot will now try to warn you if you open it in two different tabs (it won’t work if it is open on two computers, or two browsers)
  • Updated Bulma (CSS framework for extensions)
  • The bot (and most extensions) is now in TypeScript, resulting in much better autocomplete when coding

Browser support

The latest versions (& latest LTS version, if applicable) of Chrome, Firefox, Opera, Safari, Edge
Internet Explorer is not supported.


I am 99% sure this will be the last rewrite of the bot. There is already a few things I’d like to change in the code, but they are minor enough that I can live with it.

The V6 bot will remain up for as long as BlockheadsFans survives, but will not longer be receiving support or updates. To install the V7 bot, you will need to change your bookmark code with the new code in the OP (updating as soon as this is posted)


#1568

Bot seems laggy, but it could just be me.


#1569

So when I click the bookmark at my console of the world in owner portal it does nothing. I’m doing this on an iPad (IOS 9.3.5). It worked on that same device a few weeks ago, but not with V7. When I edited the bookmark V6 again it didn’t work either.


#1570

Wondering the new code for the message bot


#1573

This is too old for V7, you need iOS 10 at least, and probably 11 for some things.

I’m guessing there was a copy/paste error here, can you post your bookmark?

It’s in the OP, I’ve updated the instructions.


Something I forgot to mention in the release notes: if you are coming from a V6 bot you will want to install the save converter extension to avoid losing data


#1575

Never mind, I tried copying it again and it worked.


#1576

Quests are broken for me, i deleted a quest and then it broke for me.

Actually my quests were not functioning popping up when i clicked them.

Now whenever i install it it gives me this error “Error adding extension: TypeError: Cannot read property ‘name’ of undefined”

And then the quests thing pops up, but i can’t add quests.


#1577

I just played around with quests for a few minutes, adding, dragging quests around, and deleting, and was unable to reproduce your issue.

What browser are you using?
What operating system?
What does running this code give? (feel free to PM if you don’t want to reveal quest codes)

localStorage.getItem('/'+worldId+'/bibliofile/quests/quests')

#1578

Google chrome
Windows 10

I can’t get any quest to appear even when I try to make one. I will need to run the code in the morning.


#1579

Message bot 7! Yay!


#1580

Decided to just wipe my cache clean again so i can get quests to decide to work again


#1581

Seems announcements don’t go to the next one.

Browser: Google Chrome
OS: Windows 10


#1582

Oops! Yep, that’s a bug. I just pushed a fix, but it could take up to an hour for the cdn to pick up on the new version. Thanks for the report.


#1583

I’ve just updated the OP with a new bookmarklet code for the V7 bot.

Updating your link is optional but if you do, when bugfixes are pushed you will be able to get them within a few minutes instead of needing to wait an hour.

(Not pasting the code here to avoid potentially outdated links if it ever has to change again, unlikely, but…)


#1584

I’m afraid to say that the previous update needs to be reverted. If you updated your link, you will need to do it again since I’ve learned that freenom (which is where I got the domain from) will sometimes take your domain for (apparently) no reason. (Thanks Wingy)

I’m just using GitHub pages now.