The owner cannot be added to the whitelist via commands


#1

I’m not entirely sure this is wrong, per say… but the error message is certainly weird! I’m the owner!

The same error message shows up if running the command from the console.


#2

I tried it on Ailes it did not let me whitelist myself but I could whitelist porky


#3

But you really don’t need too? But it just seems weird that you can’t do it?

i’m on the middle for this one


#4

I’m not sure this is a bug but part of the design.

If a world is whitelisted, owner and admins can still log in to that world by default. I’m not sure about mods but I think they can too.

Which means to me that:

  1. by default, they already have those permissions set to ‘allow login’
  2. The permissions aspect can’t be changed for this type of player.

However, the permissions aspect of regular players CAN be changed, and thus they can be either blacklisted or whitelisted.

If that’s confusing, imagine owners and staff are like vanilla/survival worlds, where certain aspects of the world are NOT customizable.

Whereas, a regular player can be considered like a custom world, where certain aspects of world CAN be customized.

Thus, the ‘login permission’ for owners and staff cannot be customized, yet can be for regular players.


#5

But why would you want to whitelist yourself?


#6

If this was true, /whitelist someadmin should tell you that, but it doesn’t. It adds the admin to the whitelist.

I believe the cause is that Dave just blocked the owner for all commands that can modify lists, without adding a different error message.


To lock the world to everyone but staff - without adding a password.


#7

This is when having a second non owner admin account comes in handy. It will even work with just whitelisting the non admin account that I use to test playability for regular players. I always have a backup ign to use in these cases.


#8

That makes sense as well.

But, it was my understanding that owners and staff could login to a whitelisted world already - without the need to actually add them to the whitelist. So, to lock the world to everyone but staff, one would simply need to whitelist the world and do nothing else.

The last time I checked that was before the update, though. Has that changed?


#9

I didn’t think owners could be listed in any way. I have to admit that’s an assumption on my part though, based on the fact that they can’t be black-listed.


#10

Trying to add the owner to either the admin list or mod list with commands produces no output, and the owner is not added to the list. It seems Dave may have just missed this case, as I doubt he intended for this rather confusing error message to show up when whitelisting.


#11

It’s the same message you get if you try to blacklist the owner. It’s as it should be.