Unsupported Device?


#1

So recently I got a new Samsung note4 but it has the software of note8 ( or note6 can’t remember) Anyways, I tried downloading blockheads but it said version is not compatible with your device. Well at first it didn’t even appear on the play store, I had to browse the Internet to the find the link of it to Google play, and when I did, it said version is incompatible with your device. I really want to play this game again, please fix this issue!


#2

2 posts were merged into an existing topic: Unsupported devices after the update


#3